- Safescan 35
- Safescan 45
- Safescan 85
- Safescan 50 / 70
-
Safescan 155 / 165 / 185
- My Safescan 155 doesn't power on immediately, is it faulty?
- The device is turning off automatically. What is causing this?
- How can I change the exit direction of the inserted banknotes?
- I get an error code when feeding a banknote. What does this mean?
- How do I select another currency on my Safescan 155?
- After the update my device doesn't start.
- Can I scan the new GBP polymer notes in all 4 directions on my Safescan 155-S?
- My counterfeit detector is not working with the Swiss Francs even though the currency setting is on CHF?
- Why is there no update possibility for the USD for my Safescan 155?
- How can I ensure the verification results are accurate?
-
+ 18...
My device displays an incorrect denomination (example: €50 is detected as €20 note), what could cause this?
Cause
Check if the device is placed near other electronic devices which transmit a radio-signal or produce a certain electromagnetic radiation. This may disturb the sensors of the detector.
Solution
Remove the device from its current location, place it somewhere else and verify if the problem still persists.
If yes, the device may need to be re-calibrated, please contact Safescan.
v1801
Check if the device is placed near other electronic devices which transmit a radio-signal or produce a certain electromagnetic radiation. This may disturb the sensors of the detector.
Solution
Remove the device from its current location, place it somewhere else and verify if the problem still persists.
If yes, the device may need to be re-calibrated, please contact Safescan.
v1801
How did we do with this article?